• Tohska
    Whenever i plug the keymander into my pc the settings light does not turn on like it used to and whenever i try to open the software I'm stuck on an infinite load screen. I have tried looking for about 3-4 hours to try and fix this as well as going and getting new cables.
  • Moderator [Derek]

    Hi Tohska,

    You have both mini USB cables connected, correct? If so, make sure you have the cable running between the console and the KeyMander connected to the Game port, and the cable running between the PC and the KeyMander to the PC port. If you do not have the KeyMander connected to the console, make sure to connect the second mini USB cable between the KeyMander Power port and either an open USB on the PC or a USB power supply (like a charger for smartphones or tablets).
  • Carlos Berndt
    Restore the firmware and re update. Your firmare may be corrupted. It was my case.
  • jbtwoonefive
    I just did a rest and I don't think it worked because my saved stuff was still in there. But every time I try to updates the program goes into loading and exits out then nothing
  • Enadi
    im having the exact issue
  • jbtwoonefive
    I read about the firmware being corrupt and redownloading it and tried that. I tried opening it through the program and with out it and I got as far as an error about the cord even though I'm usi g the ones they sent. Even though the box was open when I got it, bass were sealed but box was open. Hope my in it is ok, I understand it takes forever to get your settings right bit I can't even get that fare cause I can't update.
  • Moderator [Marco]

    Were you going through the software when it failed? If so you can also try the firmware recovery steps here .
  • jbtwoonefive
    Yea I tryed that a few times but I don't think my box reset because my profile I saved was still on there on the first boot up. Is that normal?
  • Moderator [Marco]

    If you keep the "gamepademulator" file it will save all profiles that you have in the software so that is normal. So even with the recovery process you could not upgrade the firmware?
Add a Comment

Welcome to the KeyMander Forum!

Welcome to the KeyMander Forum! We encourage a community of KeyMander enthusiasts to help and support other members. As a member, you can share and download game profiles, share tips and tricks, and get the latest information about the KeyMander.

By submitting information to us, you acknowledge and agree that IOGEAR will collect and process that information about you in a manner consistent with our Privacy Policy