• Seminole1
    0
    Just got my keymander last night, Updated firmware, got everything hooked up. Loaded a bf5 profile from here , got in the game , keyboard seems to work ok, but the mouse was TERRIBLE. Very very unplayable, every movement when i moved the mouse would take it like 10 seconds to move and at a snails pace at that ! I adjusted my mouse to 6400 DPI on the software ( its a blackweb RGB mouse) I have it hooked into my PC and console , i try the simulation mode and i cant switch back to pc , i had to unplug it to get it to go back. Even in play mode i cant get it to go back to the PC without unplugging it. I need some help please.
    On xbox one
    logitech wireless keyboard ( seems to work fine)
    Blackweb rbg mouse
  • Moderator [Marco]
    71

    Did you make all the in game adjustments that were shown on the profile page as well?

    When you are using Play mode do you have the keyboard connected to your PC or the Keymander? It should be connected to the PC, if it is connected to Keymander it will not work.
  • Seminole1
    0
    I’ve pretty much got it to work , I hooked directly into the keymander with the M&k , everything seems to run ok now !
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment

Welcome to the KeyMander Forum!

Welcome to the KeyMander Forum! We encourage a community of KeyMander enthusiasts to help and support other members. As a member, you can share and download game profiles, share tips and tricks, and get the latest information about the KeyMander.

By submitting information to us, you acknowledge and agree that IOGEAR will collect and process that information about you in a manner consistent with our Privacy Policy