• Oldridge
    0
    Currently running a

    Logitech G19s Keyboard and a Logitech G400s mouse.

    I got keymander about a week ago and finally got a chance to set it up.

    First thing I did was download the software (i wasn't given a CD) and I updated the firmware.

    Once that was done I connected my keyboard and mouse to the keymander so I could do simulation to test out my mapping and mouse settings.

    Unfortunately neither works when plugged into the keymander.

    Currently the keymander is set up Power micro to USB on PC and PC micro to PC USB.

    edit: the keyboard and mouse do not work while trying to use the console as well.
  • Oldridge
    0
    I tried a generic keyboard and mouse from dell (so I am using two keyboards) and it still won't work. I've followed every guide you have and the video you have on youtube and it still isnt working. really disappointing.
  • Oldridge
    0
    Okay, so I routed the problem to the software. I tried a connection without using the keymander software and it works but not very well. Even with acceleration off there is still a little bit and about every 2-3mins it says the controller is disconnected yet the power is still on (i took the battery out) so I have to unplug and plug it back in.

    After removing all keymander software from my PC and redownloading and installing everything again I am able to get it to work with a generic keyboard and my logitech g400s but not with my G19s keyboard. The keymander on and off makes funny noises when running the software and still continues to say the controller is disconnected.

    I would really appreciate some support with this issue.

    Thanks.
  • Moderator [Marco]
    65

    Okay first can you tell me what version Xbox you have and in which port is the keymander connected on to it.

    Have you tried connected the G19 to your PC and running simulation that way? Or did you have the Keyboard hooked up directly to the keymander when you tried this?
  • Oldridge
    0
    I have an Xbox One S. I got it January this year.

    I tried with the G19 to PC and to the keymander,

    The keymander was plugged into the front USB slot on the Xbox.
  • Moderator [Marco]
    65

    What were the results when you tried it through simulation mode? Lets test the connection from the controller to the keymander. To test the cable shutoff the controller then reconnect it to the keymander ( make sure xbox is on ). If the controller turns on and stays on then it is a good cable. If it buzzes and turns off then it is just a charging cable.
  • Oldridge
    0
    Simulation mode had the same results. The controller remains on. I left it for about 30minutes. My Xbox went idle but the controller was still on.
  • Moderator [Marco]
    65

    Do you have anything going into the GAME port on the keymander? That is where the console should be connected.
  • Oldridge
    0
    So I stopped using the keymander software entirely because it would lock up and or cause delay.

    Without the keymander software running off PC to Keymander and just Keymander to console my G19s now works along with my Logitech G400s mouse.

    I have the "Game" port connected to the console on the front USB which is then connected to the Keymander via the "Game" port.

    I bought a new cable for my wireless controller (took the battery out) I still get my console saying the controller has been disconnected(it's still powered on). When this happens I get a semi-high pitch whine coming out of my speakers or headphones. When I unplug the controller and plug it back in it works again for a bit then it disconnects again and the same noise is repeated.

    As for the keymander software I don't know what to do because nothing will function properly when I use it. My G19s keyboard does not work when I use the software either. Only a generic keyboard works.
  • Moderator [Marco]
    65

    When you are using the G19 with the software is the keyboard connected to the PC or to the Keymander?

    Which generic keyboards have you tried?
  • Oldridge
    0
    The G19s is connected to the Keymander.

    The generic keyboard is just a dell brand keyboard from an old computer.
  • Moderator [Marco]
    65

    Try using simulation mode again but connect the keyboard to the PC not the keymander.
  • Oldridge
    0
    The keyboard is not responsive when plugged into the PC while running simulation mode with the mouse plugged into the PC as well it is not responsive.

    If I run just the keyboard in the PC and the mouse in the keymander the mouse is able to aim but there is a constant glide effect. IE the mouse won't stop moving in a direction when you move it left or right, up or down it will persist and you will spin in circles.

    I tried the same thing with the generic keyboard and it too is not responsive when plugged into the PC while running simulation mode.
  • Moderator [Marco]
    65

    What port do you have the PC connected to on the keymander ? This is all very strange behavior I have not seen before. Have you upgraded the firmware again?
  • Oldridge
    0
    The PC is connected to the PC port on the Keymander. Firmware was up to date as of today.
  • Oldridge
    0

    So this is what I've done. And it "works" but there are still some problems. I removed all keymander software from my computer etc. I set it all back up again. I downgraded my firmware, then upgraded the firmware. After doing this I am able to use my keyboard (G19s) and my mouse (G400s) while connected to my PC running playmode on the keymander.

    Here are the issues now:

    • 1. Controller will disconnect. (Not as often as before but it still does)
    • 2. Keymander will just stop working randomly and in order to fix this issue I have to continuously unplug and re-plug the controller, PC, and console from the keymander and eventually after a couple minutes of fiddling with it it will start working again.
    • 3. There is an issue with latency between the keymander and my PC. At times my character in game (BF1) will just start walking on their own and then it will stop and sometimes it will continue until I get a controller disconnected prompt.
    • 4. The mouse on occasion will have drift and I cannot stop it. I'll be forced to run and hide until it stops and I can then resume "normal" play.
    • 5. When I am prone my character will just keep moving and the mouse will continue to drift. Essentially making any game play while prone impossible.
    • 6. I cannot, I repeat I cannot have my headset plugged into my controller while running keymander as it will just lock up keymander after a few minutes and the high pitch audio tone will come on until I disconnect the controller and reconnect it.
    • 7. I cannot have my AUX cord from my speakers go into my controller and the same problem from #6 will happen as well. I have to run my AUX cord into my monitor or plug in my headset into my monitor for sound but then I am unable to use my mic because it is not plugged into the controller.
    • 8. I have tried this on 3 seperate controllers and I get the same results.
  • Oldridge
    0


    Alright so this is what I have done. I removed any and everything from keymander from my computer. After that was done I reinstalled everything. I then downgraded my firmware and then upgraded my firmware to the latest version and I am now able to "play" using my G19s and G400s while connected to my PC while running Playmode through the keymander software.

    Here is a list of issues that are still persistent:

    • 1. My controller still disconnects. Not as often as before but it still happens
    • 2. The keymander will stop responding at times and my character will move on his own until it stops or until I am prompted with a controller disconnect.
    • 3. Mouse drift is still an issue. Sometimes the mouse will drift and I have no control over it and I am forced to run and hide until the issue stops and then I can resume "normal" game play.
    • 4. I cannot be prone while in game. If I go prone my character will continually move and the mouse will drift. Essentially making prone play impossible.
    • 5. There seems to be some kind of latency issue between the keymander and my PC as often controls will be delayed or non responsive.
    • 6. I cannot plug in my headset or my speakers into my controller for sound as it will lock up keymander after a few minutes and the high pitch whine sound will persist until I unplug the controller and sound.
    • 7. I have tried this on 3 separate controllers and have had the same results on all of them.
  • Moderator [Marco]
    65

    Okay at this point I think getting the keymander replaced might be the best option. The issues you are having should not be happening after everything we have done. Send me a DM so we can figure out how to get you a replacement.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment

Welcome to the KeyMander Forum!

Welcome to the KeyMander Forum! We encourage a community of KeyMander enthusiasts to help and support other members. As a member, you can share and download game profiles, share tips and tricks, and get the latest information about the KeyMander.