• monkaS
    0
    I'm having issues trying to update the firmware on my Keymander to the latest version. I have all three ports connected to the correct systems (PC/Power to PC, Game to Console) and I also have my Controller connected to the Gamepad port. I've opened the software and it correctly detects my Keymander and notifies me that I am in need of a firmware update. I go to help>update firmware and click on the firmware file. It loads for a few seconds and then the FW update opens. Almost instantly it will say "No HID Device attached to the USB port [code: 4183]" and fail. Is there something I'm doing wrong?
  • monkaS
    0
    EDIT: Whenever I open the FW Update file through the Software the 'Power' light will begin to flash. If I open the FW Update by itself it will fail but the 'Power' light wont flash. Also worth mentioning that through the Software the 'Setting' light is on, and by the FW the 'Setting' light is off.
  • monkaS
    0
    UPDATE: After searching a lot of threads and solutions the 'Firmware Recovery' worked. Thanks!
  • Moderator [Marco]
    71

    Sorry we didn't get to you sooner! But glad to hear you found the information needed, let us know if you need further assistance.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment

Welcome to the KeyMander Forum!

Welcome to the KeyMander Forum! We encourage a community of KeyMander enthusiasts to help and support other members. As a member, you can share and download game profiles, share tips and tricks, and get the latest information about the KeyMander.

By submitting information to us, you acknowledge and agree that IOGEAR will collect and process that information about you in a manner consistent with our Privacy Policy